PyQt4在Windows中使用了DirectX作为加速,不过,PyQt4没有使用最新的DirectX库(应该是使用的DirectX9)。在最新的Windows 8中,并不包括这些旧版本的DirectX,这就导致了PyQt4工作不正常,并对Eric5的安装造成影响。

安装Eric5时,会碰到以下错误提示:

Checking dependencies
Python Version: 3.3.1
Found PyQt4
Sorry, please install QtHelp.
Error: DLL load failed: 找不到指定的模块。
Press enter to continue…

这是因为缺少DirectX库导致了这个问题。解决方法:
去微软的官方网站下载DirectX在线安装程序:
http://www.microsoft.com/zh-cn/download/details.aspx?id=35
然后根据提示安装DirectX库即可(可以看到安装的库大部分是2006~2008年的)。